Page tree




TLS Deprecation

Your Security Is Our Top Priority


Outdated web browsers place you at risk!  They use Version 1.0 or Version 1.1 of the Transport Layer Security (TLS) communications protocol to encrypt your data.  TLS v1.0 and TLS v1.1 are vulnerable to compromise, threatening the security of your data, and that is unacceptable to us.


As a result, starting on February 7, 2020, Exostar will no longer support versions of web browsers that rely on TLS v1.0 or TLS v1.1.  If you try to connect to the Exostar network using one of these browsers, you will be denied access.


Check your browser on this test URL by salesforce.com: https://tls1test.salesforce.com/s/.


Why wait another day?  Here’s all you need to do to protect yourself – upgrade your browser to one of the following:

Browser

Version

Google Chrome

30 and later

Internet Explorer

11

Microsoft Edge

12 and later

Mozilla Firefox

27 and later

Opera

12.1, 17 and later

Safari

7 and later


The sooner you upgrade, the sooner we all can rest easy that your data is safe!  If you need assistance with the upgrade, contact your IT department.  We will work with them as needed to keep you connected and secure.


Thanks for your support!


How useful was this content?

Your Rating: Results: 1 Star2 Star3 Star4 Star5 Star 17 rates